poj 2785

4 Values whose Sum is 0
Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 18686   Accepted: 5546
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

Southwestern Europe 2005


注意双向枚举,否则单向处理的话会超时。
#include<cstdio>
#include<cstring>
#include<algorithm>
  
using namespace std;
  
int n;
const int N=5000;
int a[N],b[N],c[N],d[N];
int cd[N*N];
int main()
{
     while ( scanf ( "%d" ,&n)!=EOF)
     {
         for ( int i=0;i<n;i++)
             {
                 scanf ( "%d" ,&a[i]);
                 scanf ( "%d" ,&b[i]);
                 scanf ( "%d" ,&c[i]);
                 scanf ( "%d" ,&d[i]);
             }
  
         int cnt=0;
         for ( int i=0;i<n;i++)
         {
             for ( int j=0;j<n;j++)
             {
                 cd[cnt++]=c[i]+d[j];
  
             }
         }
         sort(cd,cd+cnt);
          long long ans=0;
         for ( int i=0;i<n;i++)
         {
  
             for ( int j=0;j<n;j++)
             {
                 int tmp=0-(a[i]+b[j]);
               //  printf("a:%d  b:%d    num:%d\n",a[i],b[i],upper_bound(cd,cd+cnt,tmp)-lower_bound(cd,cd+cnt,tmp));
                 ans+=upper_bound(cd,cd+cnt,tmp)-lower_bound(cd,cd+cnt,tmp);
  
  
             }
  
         }
         printf ( "%lld\n" ,ans);
  
  
  
     }
  
     return 0;


你可能感兴趣的:(poj 2785)