九度oj:1049题,字符串去特定字符

题目描述:

输入字符串s和字符c,要求去掉s中所有的c字符,并输出结果。

输入:

测试数据有多组,每组输入字符串s和字符c。

输出:

对于每组输入,输出去除c字符后的结果。

样例输入:
heallo
a
样例输出:
hello
import java.util.*;

class Main{
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		
		while(input.hasNext()) {
			String str = input.nextLine();
			String c4Find = input.nextLine();
			char c = c4Find.charAt(0);
			
			String temp = "";
			for(int i = 0; i < str.length(); i++) {
				char c1= str.charAt(i);
				if(c1 != c) {
					temp += c1;
				}
			}
			System.out.println(temp);
		}
	}	
}


  这里要特别注意,oj的class类名有严格的要求,一定要取名为:Main,否则会编译不通过。

你可能感兴趣的:(算法,字符串,内存,九度OJ)