POJ1979 Red and Black

连接:http://poj.org/problem?id=1979

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21462   Accepted: 11476

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
主要用到的是深度搜索dfs函数。
#include<cstdio>
char field[20][21];
int w,h,ans;
int dfs(int x,int y)
{
    field[x][y]='#';
    ans++;
    int dx[4]={0,0,-1,1},dy[4]={1,-1,0,0};
    for(int i=0;i<4;i++)
    {
        int nx=dx[i]+x;
        int ny=dy[i]+y;
        if(0<=nx&&nx<h&&0<=ny&&ny<w&&field[nx][ny]=='.')
        {
            dfs(nx,ny);

        }
    }
    return ans;
}
int main(void)
{
    while(1)
    {
        scanf("%d%d",&w,&h);
        if(w==0&&h==0)
        {
            break;
        }
        for(int i=0;i<h;i++)
        {
            scanf("%s",field[i]);
        }
        ans=0;
        int flag=0;
        for(int i=0;i<h;i++)
        {
            for(int j=0;j<w;j++)
            {
                if(field[i][j]=='@')
                {
                    dfs(i,j);
                    flag=1;;
                    break;
                }
            }
            if(flag)
            {
                break;
            }
        }
        printf("%d\n",ans);

    }
    return 0;
}
MEMERY  164K TIME            0MS


你可能感兴趣的:(C++,poj)