Trie树入门题目--HDU1671 Phone List

Phone List Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7265    Accepted Submission(s): 2501


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input
2
3
911
97625999
91125426

5
113
12340
123440
12345
98346

Sample Output
NO
YES



字典树入门题目。。
/*************************************************************************
* author:crazy_石头
* algorithm:Trie
* date:2013/09/29
**************************************************************************/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>

using namespace std;
 

struct TrieNode
{
  int cnt;
  TrieNode* next[10];
  TrieNode()
  {
    cnt=0;
    memset(next,0,sizeof(next));
  }
};

TrieNode* root=new TrieNode;

void build(char* s)
{
    TrieNode* p=root;
    int len=strlen(s);
    for(int i=0;i<len;i++)
    {
        if(!p->next[s[i]-'0'])
        p->next[s[i]-'0']=new TrieNode;
        p=p->next[s[i]-'0'];
        p->cnt++;
    }
}

int Search(char* s)
{
    TrieNode* p=root;
    int len=strlen(s);
    for(int i=0;i<len;i++)
        p=p->next[s[i]-'0'];
    return p->cnt;
}

void Del(TrieNode* p)
{
    for(int i=0;i<10;i++)
    {
        if(p->next[i]!=NULL)
            Del(p->next[i]);
    }
    free(p);
}

int main()
{
    int t,n,i;
    char str[10001][30];
    scanf("%d",&t);
    while(t--)
    {
        root=new TrieNode;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            build(str[i]);
        }
        int flag=0;
        for(i=0;i<n;i++)
        {
            if(Search(str[i])!=1)   
            {
                flag=0;
                break;
            }
            flag=1;
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
        Del(root);
    }
    return 0;
}

你可能感兴趣的:(Trie树入门题目--HDU1671 Phone List)