hdu1019——Least Common Multiple

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42668    Accepted Submission(s): 16035


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
   
   
   
   
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
   
   
   
   
105 10296

题目是求一些数的最小公倍数,用辗转相除法,主要是寒假复习,并不是什么难点!

#include<iostream>
#include<cstring>
#include<string>
#include<queue>
#include<cmath>
#include<stack> 
#include<vector>
#include<iomanip>
#include<algorithm>
#include<cctype>
#include<cstdlib>
#include<cstdio>
using namespace std;
int lcm(int a,int b)
{
	int r,x=a,y=b;
	while(b)
	{
		r=a%b;
		a=b;
		b=r;
	}
	return x/a*y;
}
int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		int tem=1,a,num[10000];
		cin>>a;
		for(int i=0;i<a;i++)
			cin>>num[i];
		
		for(int i=0;i<a;i++)
			tem=lcm(tem,num[i]);
			
		cout<<tem<<endl;
	}
	return 0;
}

我只想做一个努力的人,加油!

你可能感兴趣的:(生活,博客,HDU)