大数相加

题目1119:Integer Inquiry

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:437

解决:228

题目描述:

    One of the first users of BIT's new supercomputer was Chip Diller.
    He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
    "This supercomputer is great,'' remarked Chip. 
    "I only wish Timothy were here to see these results.''
    (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

输入:

    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

    The final input line will contain a single zero on a line by itself.

输出:

    Your program should output the sum of the VeryLongIntegers given in the input.

样例输入:
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
样例输出:
370370367037037036703703703670
提示:

注意输入数据中,VeryLongInteger 可能有前导0


AC代码:


import java.util.*;
import java.math.*;
public class Main11 {
public static void main(String agrs[]){
Scanner cin=new Scanner(System.in);
BigInteger sum,temp;
sum=BigInteger.ZERO;
temp=cin.nextBigInteger();
sum=temp;
while(cin.hasNext()){
temp=cin.nextBigInteger();
if(temp.equals(BigInteger.ZERO))break;
sum=sum.add(temp);
}
System.out.println(sum);
}
}

你可能感兴趣的:(java,ACM)