sicily 1162. Sudoku

1162. Sudoku

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB , Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107


Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127 


题目分析

看题目,深搜

注意数字要在每行,每列,每个块中唯一

直接深搜注意两点,否则超时

一,标记为零的区域,而不是整个盘扫一遍去判断某个位置是否需要填数

二,开三个标记数组,确定在某行,某列,某小宫格是否已经有了某个数字

题目确保有解,所以一旦填完所有的空即可返回

#include <cstdio>
#include <iostream>
#include <memory.h>

bool inRow[10][10]; // if inRow[i][j] == true, means there is a digit --j, in ith row
bool inCol[10][10];
bool inBlock[10][10];
int suduku[10][10];
int test[81][2]; // record the position of the undefined cells
int count; // record the num of the undefined cells
bool doit;

int getBlockId(int x, int y) {
  return (x-1)/3*3 + (y-1)/3 + 1;
}

void dfs(int index) {
  int row = test[index][0];
  int col = test[index][1];
  for (int i = 1; i <= 9 && !doit; ++i) {
    if (inRow[row][i] || inCol[col][i] || inBlock[getBlockId(row,col)][i])
      continue;
    suduku[row][col] = i;
    inRow[row][i] = true;
    inCol[col][i] = true;
    inBlock[getBlockId(row,col)][i] = true;
    ++index;
    if (index == count) {
      doit = true;
      return;
    }
    dfs(index);
    if (doit) {
      return;
    } else {
      --index;
      suduku[row][col] = 0;
      inRow[row][i] = false;
      inCol[col][i] = false;
      inBlock[getBlockId(row,col)][i] = false;
    }
  }
}

int main() {
  int num;
  scanf("%d", &num);
  while (num--) {
    memset(inRow, 0, sizeof(inRow));
    memset(inCol, 0, sizeof(inCol));
    memset(inBlock, 0, sizeof(inBlock));
    count = 0;
    doit = false;
    std::string str;
    for (int i = 1; i <= 9; ++i) {
      std::cin >> str;
      for (int j = 1; j <= 9; ++j) {
        suduku[i][j] = str[j-1] - '0';
        if (suduku[i][j]) {
          inRow[i][suduku[i][j]] = true;
          inCol[j][suduku[i][j]] = true;
          inBlock[getBlockId(i,j)][suduku[i][j]] = true;
        } else {
          test[count][0] = i;
          test[count][1] = j;
          count++;
        }
      }
    }

    dfs(0);
    for (int i = 1; i <= 9; ++i) {
      for (int j = 1; j <= 9; ++j)
        printf("%d", suduku[i][j]);
      printf("\n");
    }
  }
}


你可能感兴趣的:(sicily 1162. Sudoku)