uva 10879 Code Refactoring(分解因子)

Code Refactoring
Time Limit: 2 seconds

"Harry, my dream is a code waiting to be
broken. Break the code, solve the crime."
Agent Cooper

Several algorithms in modern cryptography are based on the fact that factoring large numbers is difficult. Alicia and Bobby know this, so they have decided to design their own encryption scheme based on factoring. Their algorithm depends on a secret code, K, that Alicia sends to Bobby before sending him an encrypted message. After listening carefully to Alicia's description, Yvette says, "But if I can intercept K and factor it into two positive integers, A and B, I would break your encryption scheme! And the K values you use are at most 10,000,000. Hey, this is so easy; I can even factor it twice, into two different pairs of integers!"

Input
The first line of input gives the number of cases, N (at most 25000). N test cases follow. Each one contains the code, K, on a line by itself.

Output
For each test case, output one line containing "Case #xK = A * B = C * D", where ABC and D are different positive integers larger than 1. A solution will always exist.

Sample Input Sample Output
3
120
210
10000000
Case #1: 120 = 12 * 10 = 6 * 20
Case #2: 210 = 7 * 30 = 70 * 3
Case #3: 10000000 = 10 * 1000000 = 100 * 100000
题目大意:给出一个数,求它的两种因子分解。

解题思路:水的要死,直接暴力,输出两组后就可以结束了。

#include<stdio.h>
#include<math.h>
int main(){
	int n;
	scanf("%d", &n);
	for (int ti = 1; ti <= n; ti++){
		int sum, cnt = 0;
		scanf("%d", &sum);
		printf("Case #%d: %d", ti, sum);
		for (int i = 2; i <= (int)sqrt(double(sum)); i++){
			if (cnt > 1)
				break;
			if (sum % i == 0){
				cnt++;
				printf(" = %d * %d", i, sum / i);
			}
		}
		printf("\n");
	}
	return 0;}

你可能感兴趣的:(uva 10879 Code Refactoring(分解因子))