2015福建省赛 fzoj Knapsack problem 2214 (01背包&转换)

 Problem 2214 Knapsack problem

Accept: 6    Submit: 9
Time Limit: 3000 mSec    Memory Limit : 32768 KB

 Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

 Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

 Output

For each test case, output the maximum value.

 Sample Input

1
5 15
12 4
2 2
1 1
4 10
1 2

 Sample Output

15
//题意:
输入n,m,n表示物品个数,m表示背包容量
接下来n行输入每个物品的体积和价值
问这个背包最多能装多大价值的物品。
//思路:
一个01一背包的题,但得转换,因为背包的容量太大,但物品的价值和很小(只有5000),所以不对背包的容量进行dp,而是转换成对物品的价值进行dp就简单了。到最后判断一下就行了。
具体看代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct zz
{
	int w;
	int v;
}q[5010];
int dp[5010];
int main()
{
	int t,n,m;
	int i,j,k;
	scanf("%d",&t);
	while(t--)
	{
		int sum=0;
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&q[i].w,&q[i].v);
			sum+=q[i].v;
		}
		memset(dp,0x3f3f3f3f,sizeof(dp));
		dp[0]=0;
		for(i=0;i<n;i++)
		{
			for(j=sum;j>=q[i].v;j--)
			{
				dp[j]=min(dp[j],dp[j-q[i].v]+q[i].w);
			}
		}
		for(i=sum;i>=0;i--)
		{
			if(dp[i]<=m)
			{
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}

你可能感兴趣的:(2015福建省赛 fzoj Knapsack problem 2214 (01背包&转换))