Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26463    Accepted Submission(s): 10175


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
   
   
   
   
2 3 4
 

Sample Output
   
   
   
   
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

 

题解:      来自  http://mars914.iteye.com/blog/1485497

可以发现一个规律:
当   n = 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 27 28 29 30 31 ...
rdigit = 1 4 7 6 5 6 3 6 9   0   1   6  3   6   5   6   7   4  9  0   1   4   7   6   5   6   3   6  9   0    ...
所以是以20为周期的规律。

code :

#include<iostream>   
using namespace std;   
int main()   
{   
    int  rdigit[20] ={0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9};   
    int n;   
    cin>>n;
    while(n--)
    {
        int temp;   
        cin>>temp;   
        cout<<rdigit[temp%20]<<endl;     
    }
    return 0;   
}    



 

你可能感兴趣的:(Rightmost Digit)