hdoj Calculate S(n) 2114 (数学规律 取余)

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9401 Accepted Submission(s): 3415


Problem Description
Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output
For each case, output the last four dights of S(N) in one line.

Sample Input
   
   
   
   
1 2

Sample Output
   
   
   
   
0001 0009
//S(n)=1^3+2^3+3^3+......+n^3可转化为S(n)=(1+2+3+......+n)^2;
知道这个转化就简单了。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
using namespace std;
int main()
{
	ll n;
	while(scanf("%lld",&n)!=EOF)
	{
		ll sum=((n*(n+1)/2%10000)*(n*(n+1)/2%10000))%10000;
		printf("%04lld\n",sum);
	}
	return 0;
}



你可能感兴趣的:(hdoj Calculate S(n) 2114 (数学规律 取余))