hdoj Chessboard 5100 (数学几何规律)

Chessboard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 913    Accepted Submission(s): 385


Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.
 

Input
There are multiple test cases in the input file.
First line contain the number of cases T ( T10000 ).  
In the next T lines contain T cases , Each case has two integers n and k. ( 1n,k100 )
 

Output
Print the maximum number of chessboard squares tiled.
 

Sample Input
   
   
   
   
2 6 3 5 3
 

Sample Output
   
   
   
   
36 24
//题意:
给你一个n,一个k,分别表示有一个n*n的正方形,有多个k*1的矩形,问在矩形不重叠的前提下,最多可以覆盖多少面积的正方形。
//思路:
就是一个数学几何的找规律题:令m=n%k,当m<=k/2时,覆盖的面积为n*n-m*m;当m>k/2时,覆盖的面积为n*n-(k-m)*(k-m).
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define ll long long
#define N 100010
#define M 1000000007
using namespace std;
int main()
{
	int t,n,k;
	scanf("%d",&t);
	while(t--)
	{
		int sum;
		scanf("%d%d",&n,&k);
		if(n<k)
		{
			printf("0\n");
			continue;
		}
		int m=n%k;
		if(m<=k/2)
			sum=n*n-m*m;
		else
			sum=n*n-(k-m)*(k-m);
		printf("%d\n",sum);
	}
	return 0;
}

你可能感兴趣的:(hdoj Chessboard 5100 (数学几何规律))