POJ 1050 To the Max (线性dp 最大子矩阵)

To the Max
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 41297
Accepted: 21905

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

Greater New York 2001


题目链接 :http://poj.org/problem?id=1050


题目大意 :给出一个n * n的方阵,求其子矩阵的各个元素和的最大值

题目分析 :将一维的最大子段和二维化,先得到求一位情况下的函数,再用其求二维的最大值


#include <cstdio>
#include <cstring>
int const MAX = 101;
int const MIN = -2147483647;

int MaxSum1(int *a, int len) //求最大子段的函数
{
    int ma = MIN, cur = 0; //因为要考虑全为负数的情况,故将max初始化为最小值;
    for(int i = 1; i <= len; i++)
    {
        cur += a[i];       //让cur累加数组中的数,cur为当前的子序列和,如果cur大于max,则赋值,
        if(cur > ma)       //若cur小于零,则将cur置零,因为再加后面的数必然不是最大的结果,
            ma = cur;
        if(cur < 0)
            cur = 0;
    }
    return ma;
}

int MaxSum2(int n, int a[][101]) //求最大子矩阵的函数
{
    int ma = MIN;                      
    int *b = new int [n + 1];         //动态分配数组b的内存,长度为n,这里数组b用来一维化二维矩阵
    for(int i = 1; i <= n; i++)        
    {
        for(int k = 1; k <= n; k++)   //初始化数组b,这里不能用memset,因为是从1-n
            b[k] = 0;
        for(int j = i; j <= n; j++)     //枚举从第i行开始的所有行的组合 (这里不用考虑列,因为列的最优解将通过MaxSum1()函数得到)
        {
            for(int k = 1; k <= n; k++)
                b[k] += a[j][k];        
            int cur = MaxSum1(b,n);     //将每种行的组合得到的最优解赋给cur
            if(cur > ma)               //若cur > max则赋值
                ma = cur;
        }
    }
    delete []b;                       
    return ma;
}

int main()
{
    int n, num[MAX][MAX];
    scanf("%d", &n);
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
            scanf("%d", &num[i][j]);
    printf("%d\n", MaxSum2(n, num));
}




你可能感兴趣的:(poj,线性dp)