NEUACM 1002

这道题要注意空格的输出。每两个string之间有一个空格,最后没有空格。

http://acm.neu.edu.cn/hustoj/problem.php?id=1002

1002: Dinner——水


Description

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

Input

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

Output

For each test of the input, output all the name of tableware.

Sample Input

3 basketball fork chopsticks2 bowl letter

Sample Output

fork chopsticksbowl

HINT


The tableware only contains: bowl, knife, fork and chopsticks.


Source

辽宁省赛2010


#include <iostream>
using namespace std;
int main()
{
	string st[10],s;
	int a,i=0;
	while(cin>>a){
		for(int m=0;m<a;m++){
			cin>>s;
			if(s=="fork"||s=="knife"||s=="bowl"||s=="chopsticks"){
				st[i]=s;
				i++;	
			}						
		}		
		for(int m=0;m<i;m++){
			if(m!=0) cout<<" ";
			cout<<st[m];
		}
		cout<<endl;
		i=0;
		
	}
	return 0;
}


你可能感兴趣的:(String,Integer,input,each,output,2010)