hdoj--3367--Pseudoforest(伪森林&&最大生成树)

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2311    Accepted Submission(s): 892


Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
   
   
   
   
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

Sample Output
   
   
   
   
3 5
 

Source
“光庭杯”第五届华中北区程序设计邀请赛 暨 WHU第八届程序设计竞赛
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3362  3368  3364  3365  3369 

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int n,m,minn,vis[10000+10],pre[10000+10];
struct node
{
	int u,v,val;
}edge[100000+10];
void init()
{
	for(int i=0;i<10010;i++)
	pre[i]=i;
}
int cmp(node s1,node s2)
{
	return s1.val>s2.val;
}
int find(int x)
{
	return pre[x]==x?x:pre[x]=find(pre[x]);
}
int main()
{
	while(scanf("%d%d",&n,&m),n||m)
	{
		init();
		for(int i=0;i<m;i++)
		scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].val);
		sort(edge,edge+m,cmp);
		minn=0;
		memset(vis,0,sizeof(vis));
		for(int i=0;i<m;i++)
		{
			int fx=find(edge[i].u);
			int fy=find(edge[i].v);
			if(fx!=fy)
			{
				if(!vis[fx]&&!vis[fy])
				{
					minn+=edge[i].val;
					pre[fx]=fy;
				}
				else if(!vis[fx]||!vis[fy])
				{
					minn+=edge[i].val;
					pre[fx]=fy;
					vis[fx]=vis[fy]=1;
				}
			}
			else
			{
				if(!vis[fx]&&!vis[fy])
				{
					minn+=edge[i].val;
					vis[fx]=vis[fy]=1;
				}
			}
		}
		printf("%d\n",minn);
	}
	return 0;
}


你可能感兴趣的:(hdoj--3367--Pseudoforest(伪森林&&最大生成树))