Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8883 Accepted Submission(s): 4086
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
/**********************
* author:maple_小贾
* Pro:HDOJ 1711
* algorithm: KMP 使用全局变量
* date:2013/11/8
***********************/
#include<cstdio>
#include<cstring>
#define MAXN 1000000+5
int next[MAXN],s[MAXN],p[MAXN];
int n,m;//主串和模式串的串长
void GetNext(int *p, int *next){
int i,j;
next[0]=-1;
i=0,j=-1;
while(i<m){
if(j==-1 || p[i]==p[j]){//如果p[j]==p[i];
i++;
j++;
next[i]=j;
}
else {//不匹配 p][j]!=p[i];
j=next[j];
}
}
}
int KMP(int *s,int *p){
GetNext(p,next);
int i,j;
i=0,j=0;
while(i<n){
if(j==-1 || s[i]==p[j]){
i++;
j++;
}
else{
j=next[j];
}
if(j==m)
return i-m+1;
}
return -1;
}
int main(){
int test;
scanf("%d",&test);
while(test--){
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&s[i]);
for(int i=0;i<m;i++)
scanf("%d",&p[i]);
printf("%d\n",KMP(s,p));
}
}