hdoj the Sum of Cube 5053 (简单数学)

the Sum of Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1971    Accepted Submission(s): 805


Problem Description
A range is given, the begin and the end are both integers. You should sum the cube of all the integers in the range.

Input
The first line of the input is T(1 <= T <= 1000), which stands for the number of test cases you need to solve.
Each case of input is a pair of integer A,B(0 < A <= B <= 10000),representing the range[A,B].

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then output the answer – sum the cube of all the integers in the range.

Sample Input
   
   
   
   
2 1 3 2 5
 
Sample Output
   
   
   
   
Case #1: 36 Case #2: 224
 
#include<stdio.h>
#include<math.h>
#define ll __int64
int main()
{
	int t,T=1;
	ll n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%I64d%I64d",&n,&m);
		ll s=(n*n*(n-1)*(n-1)/4);
		ll ss=(m*m*(m+1)*(m+1)/4);
		ll sum=ss-s;
			printf("Case #%d: %I64d\n",T++,sum);
	}
	return 0;
} 

你可能感兴趣的:(hdoj the Sum of Cube 5053 (简单数学))