hdoj Candy Sharing Game 1034 (简单递推)

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4425    Accepted Submission(s): 2698


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input
   
   
   
   
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0

Sample Output
   
   
   
   
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
//题意:
老师给n个人偶数个糖果,老师每吹一次哨子,所有人将自己的一半糖果给他右边的人,当有人糖果是奇数时,老师会再给她一个,直到所有人的糖果数一样时结束,问吹了几次哨子,每个人有几个糖果。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1010];
int b[1010];
int n;
int judge()
{ 
	int i;
	for(i=0;i<n;i++)
	{
		b[i]=(a[i]+a[i+1])/2;
		if(b[i]&1)
			b[i]++;
	}
	int cnt=1;
	for(i=1;i<n;i++)
		if(b[i]!=b[i-1])
			cnt++;
	if(cnt==1)
		return 0;
	else
		return 1;
}
int main()
{
	int m,i,j,k,l;
	while(scanf("%d",&n),n)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		a[n]=a[0];
		int cnt=0; 
		while(1)
		{
			if(judge())
			{
				for(i=0;i<n;i++)
					a[i]=b[i];
				a[n]=a[0];
				cnt++;
			}
			else
				break;
		}
		printf("%d %d\n",cnt+1,b[1]);
	}
	return 0;
}

你可能感兴趣的:(hdoj Candy Sharing Game 1034 (简单递推))