UVaoj The Cat in the Hat 107 (数论&&精度)

The Cat in the Hat
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

Background

(An homage to Theodore Seuss Geisel)

The Cat in the Hat is a nasty creature,
But the striped hat he is wearing has a rather nifty feature.

With one flick of his wrist he pops his top off.

Do you know what's inside that Cat's hat?
A bunch of small cats, each with its own striped hat.

Each little cat does the same as line three,
All except the littlest ones, who just say ``Why me?''

Because the littlest cats have to clean all the grime,
And they're tired of doing it time after time!

The Problem

A clever cat walks into a messy room which he needs to clean. Instead of doing the work alone, it decides to have its helper cats do the work. It keeps its (smaller) helper cats inside its hat. Each helper cat also has helper cats in its own hat, and so on. Eventually, the cats reach a smallest size. These smallest cats have no additional cats in their hats. These unfortunate smallest cats have to do the cleaning.

The number of cats inside each (non-smallest) cat's hat is a constant, N. The height of these cats-in-a-hat is  times the height of the cat whose hat they are in.

The smallest cats are of height one;  
these are the cats that get the work done.
All heights are positive integers.

Given the height of the initial cat and the number of worker cats (of height one), find the number of cats that are not doing any work (cats of height greater than one) and also determine the sum of all the cats' heights (the height of a stack of all cats standing one on top of another).

The Input

The input consists of a sequence of cat-in-hat specifications. Each specification is a single line consisting of two positive integers, separated by white space. The first integer is the height of the initial cat, and the second integer is the number of worker cats.

A pair of 0's on a line indicates the end of input.

The Output

For each input line (cat-in-hat specification), print the number of cats that are not working, followed by a space, followed by the height of the stack of cats. There should be one output line for each input line other than the ``0 0'' that terminates input.

Sample Input

216 125
5764801 1679616
0 0

Sample Output

31 671
335923 30275911
 
题意:

一隻神奇聰明貓走進了一間亂七八糟的房間,他不想自己動手收拾,他決定要找幫手來工作。於是他從他的帽子中變出了N隻小貓來幫他(變出來的貓,高度為原來貓的 1/(N+1) )。這些小貓也有帽子,所以每一隻小貓又從他的帽子中變出N隻小小貓來幫他。如此一直下去,直到這些小小小....貓小到不能再小(高度=1),他們的帽子無法再變出更小的貓來幫忙,而這些最小的貓只得動手打掃房間。注意:所有貓的高度都是正整數。

在這個問題中,給你一開始那隻貓的高度,以及最後動手工作的貓的數目(也就是高度為1的貓的數目)。要請你求出有多少隻貓是沒有在工作的,以及所有貓的高度的總和。

    
    
    
    
解题思路:
这个题,假设第一只猫每次可以分出q只猫出来。
并且总共分了n次。
那么
就有如下方程:
(1/h)=(1/(q+1))^n
w=q^n
直接解这个方程,是高次的,木有办法直接求出来。只能够用二分算法解。
解得q,n之后,剩下的非常好做了。两个都是等比数列求和就行了。
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define E 1e-12
using namespace std;
double f(double h,double n)
{
	double tmp;
	tmp=pow(h,1.0/n)+E;
	return pow(tmp-1,n)+E;
}
int main()
{
	int k;
	double h,w,q,n;
	double l,r,mid;
	double ans1,ans2;
	while(scanf("%lf%lf",&h,&w),n&&w)
	{
		l=0;r=62;
		for(k=1;k<=100;k++)
		{
			mid=(l+r)/2;
			double tmp=f(h,mid);
			if(tmp>w)
				l=mid;
			else
				r=mid;
		}
		n=mid;
		q=pow(h,1.0/n)+E-1;
		ans1=(1-pow(q,n))/(1-q);
		ans2=h*(1-pow(q/(q+1),n+1))*(q+1);
		printf("%.0lf %.0lf\n",ans1,ans2);
	}
	return 0;
}

//我是这样写的,感觉是对的,但一直WA,看了大神的博客才知道貌似这是精度问题。唉,坑了一晚上。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
using namespace std;
int main()
{
	ll n,m;
	int i,j,k,kk;
	while(scanf("%lld%lld",&n,&m),n&&m)
	{
		int flag=0;
		for(i=2;i<=sqrt(m);i++)
		{
			if(m%i==0)
			{
				for(j=1;j<=1010;j++)
				{
					if(pow(i+1,j)==n&&pow(i,j)==m)
					{
						flag=1;
						break;
					}	
				}
				if(flag)
					break;
			}
			if(flag)
				break;
		}
		ll num=0;
		ll sum=0;
		for(k=0;k<j;k++)
			num+=pow(i,k);
		for(kk=0;kk<=j;kk++)
			sum+=(pow(i,kk)*n/pow(i+1,kk));
		//printf("%d %d\n",i,j);
		printf("%lld %lld\n",num,sum);
	}
	return 0;
}

你可能感兴趣的:(UVaoj The Cat in the Hat 107 (数论&&精度))