[poj 2492 ] A Bug's Life 并查集应用

A Bug’s Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 33074 Accepted: 10837

Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint
Huge input,scanf is recommended.

Source
TUD Programming Contest 2005, Darmstadt, Germany

题目链接
题意
思路
二分图的并查集;详见http://blog.csdn.net/alps233/article/details/51065865
每个点建个新点,作union
find(aa)==find(bb)即有同性恋
代码

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int T;
int fa[4005];
int n,m;
int aa,bb;
int flag;
void init(int n)
{
    for(int i=1;i<=n;i++)
    fa[i]=i;
}
int find(int x)
{
    if(x==fa[x]) return x;
    else return fa[x]=find(fa[x]);
}
void unio(int x,int y)
{
    fa[find(x)]=find(y);
}
int main()
{
    int cnt=0;
    scanf("%d",&T);
    while(T--)
    {
        cnt++;

        scanf("%d%d",&n,&m);
        init(2*n);
        flag=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&aa,&bb);
            if(flag) continue;
            if(find(aa)==find(bb))
            {
                flag=1;
                continue;
            }
            unio(aa+n,bb);
            unio(aa,bb+n); 
        }
        printf("Scenario #%d:\n",cnt);

        if(flag)
        printf("Suspicious bugs found!\n"); 
        else printf("No suspicious bugs found!\n");
    }
}

你可能感兴趣的:(poj)