[poj 3254] Corn Fields  状态压缩DP(递推)

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11605 Accepted: 6078

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input
Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint
Number the squares as follows:

1 2 3
4

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source
USACO 2006 November Gold

题目链接:http://poj.org/problem?id=3254

题意:给你一个0,1矩阵,1代表可取,问不相邻取的方法数

思路
1.明显的递推:dp[i][j]+=dp[i-1][p]..(前i行,第j状态的方法数)

2.n<=15—>状态压缩;

3.*优化,预处理可行状态:(相邻的处理)return x&(x<<1);存在st【】中;
判断2:上下return x&y;
判断3:与0,1图的匹配:

        scanf("%d",&aa);
        if(!aa)
        ma[i]+=(1<<(j-1));

若j状态在ma【i】中合法,st【j】&ma【i】==0

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define N 13
#define M (1<<N)
#define mod 100000000
int st[M],ma[N];
int dp[N][M];
bool C(int x)
{
    return x&(x<<1);
}
bool can(int x,int y)
{
    return x&y;

}
int main()
{
    int n,m,x;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)   
    for(int j=1;j<=m;j++)
    {
        int aa;
        scanf("%d",&aa);
        if(!aa)
        ma[i]+=(1<<(j-1));
    }
    int k=0;
    for(int i=0;i<(1<<m);i++)
    if(!C(i))    st[++k]=i;
    for(int i=1;i<=k;i++)  
    if(!can(st[i],ma[1]))   dp[1][i]=1;

    for(int i=2;i<=n;i++)
    for(int j=1;j<=k;j++)
    {
        if(can(ma[i],st[j])) continue;
        for(int p=1;p<=k;p++)//枚举上一层的状态
        if(!can(ma[i-1],st[p])&&!can(st[j],st[p]))
        dp[i][j]+=dp[i-1][p];
    }   

    int ans=0;
    for(int i=1;i<=k;i++)
    {
        ans+=dp[n][i];
        ans%=mod;

    }
    printf("%d\n",ans);


}

你可能感兴趣的:(压缩,poj)