杭电2674 N!Again

Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!


 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.


 

Output
For each case, output N! mod 2009


 

Sample Input
   
   
   
   
4 5


 

Sample Output
   
   
   
   
24 120
把结果保存在数组里比较省时间
 
#include<stdio.h>
int a[41];
int fun()
{
	int i;
	a[0]=1;a[1]=1;a[2]=2;
	for(i=3;i<=40;++i)
	{
		a[i]=a[i-1]*i%2009;
	}
}
int main()
{
	int n;
	fun();
	while(~scanf("%d",&n))
	{
		if(n<=40)
		printf("%d\n",a[n]);
		else printf("0\n");
	}
	return 0;
}


 

你可能感兴趣的:(杭电2674 N!Again)