ZOJ 2829 Beautiful Number

Beautiful Number Time Limit: 2 Seconds      Memory Limit: 65536 KB

Mike is very lucky, as he has two beautiful numbers, 3 and 5. But he is so greedy that he wants infinite beautiful numbers. So he declares that any positive number which is dividable by 3 or 5 is beautiful number. Given you an integer N (1 <= N <= 100000), could you please tell mike the Nth beautiful number?

Input

The input consists of one or more test cases. For each test case, there is a single line containing an integer N.

Output

For each test case in the input, output the result on a line by itself.

Sample Input

1
2
3
4

Sample Output

3
5
6

9

这个题目的各种信息表示,输出是有规律而言的,

0    1     2  3     4     5    6    7

3    5     6   9  10    12    15

18  20  21  24  25    27    30

就是七个一循环,所以代码就很容易了:

#include<iostream>
#include<cstdio>
using namespace std;
int a[7]={3,5,6,9,10,12,15};
int main()
{
    int n,m,p;
    long long sum;
    while(~scanf("%d",&n))
    {
             m=n/7;
             p=n%7;
             sum=a[p-1]+m*15;
             printf("%lld\n",sum);
    }
    return 0;
}


你可能感兴趣的:(ZOJ,规律)