POJ2524Ubiquitous Religions

Description

当今世界有很多不同的宗教,很难通晓他们。你有兴趣找出在你的大学里有多少种不同的宗教信仰。
你知道在你的大学里有n个学生(0 < n <= 50000) 。你无法询问每个学生的宗教信仰。此外,许多学生不想说出他们的信仰。避免这些问题的一个方法是问m(0 <= m <= n(n - 1)/ 2)对学生, 问他们是否信仰相同的宗教( 例如他们可能知道他们两个是否去了相同的教堂) 。在这个数据中,你可能不知道每个人信仰的宗教,但你可以知道校园里最多可能有多少个不同的宗教。假定每个学生最多信仰一个宗教。

Input

有多组数据。对于每组数据:
第一行:两个整数n和m。
以下m行:每行包含两个整数i和j,表示学生i和j信仰相同的宗教。学生编号从1到n。
输入的最后一行中,n = m = 0。

Output

对于每组测试数据,输出一行,输出数据序号( 从1开始) 和大学里不同宗教的最大数量。(参见样例)

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

输入巨大,推荐使用scanf。
代码:
#include<iostream>
#include<algorithm>
using namespace std;
int pre[50001];
int find(int x)
{
	int r=x;
	while(r!=pre[r])
	{
		r=pre[r];
	}
	
	int i=x,j;
	while(i!=r)
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}
void join(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
	}
}
int main()
{
	int n,m;
	int k=0;
	while(scanf("%d%d",&n,&m)&&n||m)
	{
		for(int i=1;i<=n;i++)
		{
			pre[i]=i;
		}
		while(m--)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			join(a,b);
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			if(pre[i]==i)
			ans++;
		}
		k++;
		printf("Case %d: %d\n",k,ans);
	}
	return 0;
}

思路:基础并查集

你可能感兴趣的:(POJ2524Ubiquitous Religions)