HDU杭电5533 Dancing Stars on Me

http://acm.hdu.edu.cn/showproblem.php?pid=5533

Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer  T  indicating the total number of test cases. Each test case begins with an integer  n , denoting the number of stars in the sky. Following  n  lines, each contains  2  integers  xi,yi , describe the coordinates of  n  stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
   
   
   
   
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
   
   
   
   
NO YES NO
 


题意:给你几个点,判断这几个点能否组成正n边形

#include <cstdio>
#define MAXN 1100
#define INF 0x3f3f3f3f
double x[MAXN],y[MAXN];
double map[MAXN][MAXN];
double fun(int i,int j)
{
	return (x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
}
int main()
{
	int T;
	int N;
	int i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&N);
		for(i=1;i<=N;++i)
		{
			scanf("%lf%lf",x+i,y+i);
		}
		double min=INF;
		for(i=1;i<=N;++i)
		{
			for(j=i+1;j<=N;++j)
			{
				map[i][j]=fun(i,j);
				if(min>map[i][j])
				{
					min=map[i][j];
				}
			}
		}
		int cnt=0;
		for(i=1;i<=N;++i)		
			for(j=i+1;j<=N;++j)				
				if(min==map[i][j])				
					cnt++;
		if(cnt==N) printf("YES\n");
		else printf("NO\n");			
	}
	return 0;
}


你可能感兴趣的:(HDU杭电5533 Dancing Stars on Me)