【POJ3267】-The Cow Lexicon dp

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9187 Accepted: 4362

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a’..’z’. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said “browndcodw”. As it turns out, the intended message was “browncow” and the two letter “d”s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a’..’z’) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input
Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..W+2: The cows’ dictionary, one word per line

Output
Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

题目链接: http://poj.org/problem?id=3267
题意: 单词删最小字母,能匹配
思路:dp[i]表示从s中第i个字符开始,到第L个字符(结尾处)这段区间所删除的字符数,初始化为dp[L]=0;
从后开始dp

dp[i]=dp[i+1]+1;
然后for每个单词删 p1,p2换

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[305];

char t[601][30];
int n,len;
int l[605];
int dp[305];
int DP()
{
    dp[len]=0;
    for(int i=len-1;i>=0;i--)
    {
        //cout<<s[6]<<endl;
        dp[i]=dp[i+1]+1;
        for(int j=1;j<=n;j++)
        if(t[j][0]==s[i]&&l[j]<=len-i)
        {

            int p1=i,p2=0;
            while(p1<len)
            {
                if(t[j][p2]==s[p1++]) p2++;
                if(p2==l[j])
                {
                    dp[i]=min(dp[i],dp[p1]+p1-i-l[j]);  
                    //cout<<i<<" "<<dp[i]<<endl;
                    break;
                }
            } 

        }
    }


    return dp[0];

}

int main()
{
    scanf("%d%d",&n,&len);
    scanf("%s",s);
    for(int i=1;i<=n;i++)
    {
        scanf("%s",t[i]);
        l[i]=strlen(t[i]);
    }

    printf("%d\n",DP());

}

你可能感兴趣的:(dp,poj)