poj 3694 Network (连通图缩点+LCA+并查集)

http://poj.org/problem?id=3694

Network
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 7432   Accepted: 2703

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

题目大意:
给你一个无向图,然后再给你一个Q代表有Q次询问,每一次加一条边之后还有几座桥。在这里要对重边进行处理。
每次加入一条边之后,在这条搜索树上两个点的公共祖先都上所有点的桥都没了。
这里我们 使用一个 bridge 数组来保存桥, 因为有重边的存在  只有 bridge 数量为 1 的时候这个路径才算是桥,否则则不是桥
bridge[i] 是指  i 和 father[i] 是一座桥
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 100005
#define INF 0xfffffff
#define PI acos (-1.0)
#define EPS 1e-8

vector <vector <int> > G;
int n, m, f[N], low[N], dfn[N], bridge[N], Time, ans;

void Init ();
void tarjan (int u, int fa);
void Lca (int a, int b);

int main ()
{
    int flag = 1;
    while (scanf ("%d%d", &n, &m), n+m)
    {
        int a, b, Q;
        Init ();
        while (m--)
        {
            scanf ("%d%d", &a, &b);
            G[a].push_back (b);
            G[b].push_back (a);
        }

        tarjan (1, 0);
        scanf ("%d", &Q);
        printf ("Case %d:\n", flag++);

        while (Q--)
        {
            scanf ("%d%d", &a, &b);
            Lca (a, b);
            printf ("%d\n", ans);
        }
    }
    return 0;
}

void Init ()
{
    G.clear ();
    G.resize (n+1);
    memset (low, 0, sizeof (low));
    memset (dfn, 0, sizeof (dfn));
    memset (f, 0, sizeof (f));
    memset (bridge, 0, sizeof (bridge));
    Time = ans = 0;
}

void tarjan (int u, int fa)
{
    low[u] = dfn[u] = ++Time;
    f[u] = fa;
    int len = G[u].size (), v, k = 0;

    for (int i=0; i<len; i++)
    {
        v = G[u][i];
        if (!k && v == fa)
        {
            k++;
            continue;
        }

        if (!dfn[v])
        {
            tarjan (v, u);
            low[u] = min (low[u], low[v]);
            if (dfn[u] < low[v])
            {
                bridge[v]++;
                ans++;
            }
        }
        else
            low[u] = min (low[u], dfn[v]);
    }
}

void Lca (int a, int b)
{
    if (a == b) return;

    if (dfn[a] > dfn[b])
    {
        if (bridge[a] == 1)
        {
            bridge[a] = 0;
            ans--;
        }
        Lca (f[a], b);
    }
    else
    {
        if (bridge[b] == 1)
        {
            bridge[b] = 0;
            ans--;
        }
        Lca (a, f[b]);
    }
}




你可能感兴趣的:(poj 3694 Network (连通图缩点+LCA+并查集))