poj 1088 滑雪 (记忆化搜索)

http://poj.org/problem?id=1088

滑雪

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

我们来需要一个数组M来保存每一个点作为起点的最长长度。然后开始DFS,注意到首先如果搜索到-1或者此点的高度比上一个点大,就回溯,因为滑雪要从高的地方到低的地方,还有就是如果M[][]如果比-1大了,证明搜索过这个点了,因为这个点的长度怎么说也比0大吧,而且我们开始把M初始化为-1了。然后开始dp 也就是坐标为x, y的点的长度是其四周的点的长度+1;

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;
typedef long long LL;

#define N 105
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-5
#define met(a, b) memset (a, b, sizeof (a))

const int dir[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};

int dp[N][N], M[N][N], n, m, ans;

int DFS (int x, int y)
{
    int ans = 0;
    if (M[x][y] != -1) return M[x][y];

    for (int i=0; i<4; i++)
    {
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];

        if (xx>0 && xx<=n && yy>0 && yy<=m && dp[xx][yy] > dp[x][y])
            ans = max (ans, DFS (xx, yy));
    }
    M[x][y] = ans + 1;
    return ans+1;
}

int main ()
{
    while (scanf ("%d %d", &n, &m) != EOF)
    {
        int maxn = 0;
        met (M, -1);
        met (dp, 0);

        for (int i=1; i<=n; i++)
        for (int j=1; j<=m; j++)
        scanf ("%d", &dp[i][j]);

        for (int i=1; i<=n; i++)
        for (int j=1; j<=m; j++)
            maxn = max (maxn, DFS (i, j));

        printf ("%d\n", maxn);
    }
    return 0;
}


你可能感兴趣的:(poj 1088 滑雪 (记忆化搜索))