【冀宝er要逆袭】HDU-4287-Intelligent IME

问题描述
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o
  7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?

输入
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.

输出
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.

样例输入

1
3 5
46
64448
74
go
in
night
might
gn

样例输出

3
2
0

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int num[2000000];

int cc(char str[])  //本函数的作用是将每个字符串都变为数字串表示
{
    int len=strlen(str);
    int ans=0;
    for(int i=0;i<len;i++)
    {
        ans*=10;
        if(str[i]>='a'&&str[i]<='c')ans+=2;
        else if(str[i]>='d'&&str[i]<='f')ans+=3;
        else if(str[i]>='g'&&str[i]<='i')ans+=4;
        else if(str[i]>='j'&&str[i]<='l')ans+=6;        
        else if(str[i]>='m'&&str[i]<='o')ans+=6;
        else if(str[i]>='p'&&str[i]<='s')ans+=7;
        else if(str[i]>='t'&&str[i]<='v')ans+=8;
        else if(str[i]>='w'&&str[i]<='z')ans+=9;
    }
    return ans;
}
int a[10000];
char str[20];
int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(num,0,sizeof(num));
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        while(m--)
        {
            scanf("%s",&str);
            num[cc(str)]++; //把每个字符串对应的数字串赋值为1
        }
        for(int i=0;i<n;i++)
          printf("%d\n",num[a[i]]);  //将数字串输出出来,如果存在对应关系则输出非零值,不存在则输出0
    }
    return 0;
}

啦啦啦

你可能感兴趣的:(对应关系)