436 sum of all integer numbers

sum of all integer numbers

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 0
描述
Your task is to find the sum of all integer numbers lying between 1 and N inclusive.
输入
There are multiple test cases.
The input consists of a single integer N that is not greater than 10000 by it's absolute value.
输出
Write a single integer number that is the sum of all integer numbers lying between 1 and N inclusive.
样例输入
3
样例输出
6

这个题就是求给出的数和1之前所有的整数的和,包括边界,需要注意的就是,可能是负数,所以提前判断一下,交换一下循环的上下限,然后循环累加就行了......看题一定要认真....要不然可能就坑了.....


#include<stdio.h>
int main()
{
	int n,i,s,j,a;
	while(scanf("%d",&n)!=EOF)
	{
		s=0;j=1;
		if(n<1)
		{
			j=n;n=1;
		}
		for(i=j;i<=n;i++)
		{
			s+=i;
		}
		printf("%d\n",s);
	}
	return 0;
}        


你可能感兴趣的:(436 sum of all integer numbers)