Cube Stacking
Time Limit: 2000MS |
|
Memory Limit: 30000K |
Total Submissions: 22163 |
|
Accepted: 7777 |
Case Time Limit: 1000MS |
Description
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2
Source
USACO 2004 U S Open
题意:有两种操作M 把X堆得碟子放到Y堆上 C X下面有几个碟子
带权并查集,以x为根结点的所有元素减去以X到根结点的距离再减一
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int i,pre[30100];
int vis[30100];//x到根节点的距离
int dis[30100];//以X为根节点元素的个数
void init()
{
for(i=1;i<=30100;i++)
{
pre[i]=i;
vis[i]=0;
dis[i]=1;
}
}
int find(int x)
{
if(x==pre[x])
return x;
else
{
int root=find(pre[x]);
vis[x]=vis[x]+vis[pre[x]];
return pre[x]=root;
}
}
void merge(int x,int y)
{
int fx=find(x);
int fy=find(y);
pre[fy]=fx;
vis[fy]=dis[fx];
dis[fx]+=dis[fy];
}
int main()
{
int t,a,b;
char str[10];
while(~scanf("%d",&t))
{
init();
while(t--)
{
scanf("%s",str);
if(str[0]=='M')
{
scanf("%d%d",&a,&b);
merge(a,b);
}
else
{
scanf("%d",&a);
int fx=find(a);
printf("%d\n",dis[fx]-vis[a]-1);
}
}
}
return 0;
}