Dancing Stars on Me
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 841 Accepted Submission(s): 458
Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.
Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.
1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.
Output
For each test case, please output “YES
” if the stars can form a regular polygon. Otherwise, output “NO
” (both without quotes).
Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0
Sample Output
NO
YES
NO
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5533
题意:给你几个点,问能否形成正多边形。
思路:坐标整点--》只可能构成正4边形
只需判定4条最短边是否相等
代码:
#include<iostream>
#include<math.h>
#include<stdio.h>
#include<string.h>
using namespace std;
double x[1005],y[1005],len[1005][1005];
int num;
double ans;
int T;
int n;
int main()
{
scanf("%d",&T);
while(T--)
{
ans=99999999;
scanf("%d",&n);
if(n!=4)
{
printf("NO\n");
continue;
}
num=0;
for(int i=1;i<=n;i++)
{
cin>>x[i]>>y[i];
}
for(int i=1;i<=n;i++)
for(int j=1+i;j<=n;j++)
{
len[i][j]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
if(ans>len[i][j])
{
ans=len[i][j];
num=0;
}
if(ans==len[i][j]) num++;
}
if(n==num)
printf("YES\n");
else
printf("NO\n");
}
}