HDU 1423 Greatest Common Increasing Subsequence(dp)

Greatest Common Increasing Subsequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 3
Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
   
   
   
   
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
   
   
   
   
2
 

Source
ACM暑期集训队练习赛(二)
求两组数据相同的最长的上升子序列,感觉学习DP,根据代码自己在纸上模拟一样过程,可以加深理解
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1100],m,n,a[1100],b[1100];
int init()
{
	int max,i,j;
    memset(dp,0,sizeof(dp));
	for(i=1;i<=m;i++)
	{
		max=0;
		for(j=1;j<=n;j++)
		{
			if(a[i]>b[j]&&max<dp[j])
			max=dp[j];
			if(a[i]==b[j])
			dp[j]=max+1;
		}
	}
	max=0;
	for(j=1;j<=n;j++)
	{
		if(max<dp[j])
		max=dp[j];
	}
	return max;
}
int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&m);
		for(i=1;i<=m;i++)
		scanf("%d",&a[i]);
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		scanf("%d",&b[i]);
		printf("%d\n",init());
		if(t)
		printf("\n");
	}
	return 0;
 } 


你可能感兴趣的:(HDU 1423 Greatest Common Increasing Subsequence(dp))