hdoj 2579 Dating with girls(2) 【BFS 取余标记】



Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2664    Accepted Submission(s): 745


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
hdoj 2579 Dating with girls(2) 【BFS 取余标记】_第1张图片
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
       
       
       
       
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
       
       
       
       
7
 



题意:给定一个c*r的地图,上面有Y G # . 四种字符。' # ' 表示该处有石头,且石头每隔k秒会消失一次(还会出现), ' . ' 表示该处是空的可以走。现在问你能否从 Y 到达 G,若可以输出最少花费,否则输出Please give me another chance!。


好难想( ⊙ o ⊙ )啊!,只是想到了对k取余,但是下面的操作还是没处理好。 太弱了 o(╯□╰)o


思路:用vis[x][y][t%k]标记。操作如下

(1) t时刻 在位置(x, y)碰到非字符#,若vis[x][y][t%k]状态未出现,标记入队。 

(2) t时刻 在位置(x, y)碰到字符#,若vis[x][y][t%k]未出现 且 t % k == 0,标记入队。


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#define INF 0x3f3f3f3f
#define debug printf("1\n")
#define MAXN 110
#define MAXM 10000
#define Ri(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define Rl(a) scanf("%lld", &a)
#define Pl(a) printf("%lld\n", (a))
#define Rs(a) scanf("%s", a)
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define LL long long
#define eps 1e-8
using namespace std;
bool vis[MAXN][MAXN][11];
char str[MAXN][MAXN];
struct Node{
    int x, y, step;
};
int c, r, k;
bool judge(int x, int y){
    return x >= 0 && x < r && y >= 0 && y < c;
}
int BFS(int x, int y)
{
    queue<Node> Q;
    int Move[4][2] = {0,1, 0,-1, 1,0, -1,0};
    CLR(vis, false);
    Node now, next;
    now.x = x, now.y = y, now.step = 0;
    Q.push(now);
    while(!Q.empty())
    {
        now = Q.front();
        Q.pop();
        if(str[now.x][now.y] == 'G')
            return now.step;
        for(int p = 0; p < 4; p++)
        {
            next.x = now.x + Move[p][0];
            next.y = now.y + Move[p][1];
            if(judge(next.x, next.y))
            {
                if(str[next.x][next.y] != '#')
                {
                    next.step = now.step + 1;
                    if(!vis[next.x][next.y][next.step%k])
                    {
                        vis[next.x][next.y][next.step%k] = true;
                        Q.push(next);
                    }
                }
                else
                {
                    next.step = now.step + 1;
                    if(!vis[next.x][next.y][next.step%k] && next.step % k == 0)
                    {
                        vis[next.x][next.y][next.step%k] = true;
                        Q.push(next);
                    }
                }
            }
        }
    }
    return -1;
}
int main()
{
    int t; Ri(t);
    int sx, sy;
    W(t)
    {
        Ri(r); Ri(c); Ri(k);
        for(int i = 0; i < r; i++)
        {
            Rs(str[i]);
            for(int j = 0; j < c; j++)
            {
                if(str[i][j] == 'Y')
                {
                    sx = i;
                    sy = j;
                }
            }
        }
        int ans = BFS(sx, sy);
        if(ans == -1)
            printf("Please give me another chance!\n");
        else
            printf("%d\n", ans);
    }
    return 0;
}



你可能感兴趣的:(hdoj 2579 Dating with girls(2) 【BFS 取余标记】)