hdoj 5533 Dancing Stars on Me 【醉了 o(╯□╰)o】



Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 10    Accepted Submission(s): 7


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer  T  indicating the total number of test cases. Each test case begins with an integer  n , denoting the number of stars in the sky. Following  n  lines, each contains  2  integers  xi,yi , describe the coordinates of  n  stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
       
       
       
       
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
       
       
       
       
NO YES NO
 



题意:给你n个点,问你这n个点能否组成正多边形(所有角都相等。。。)

思路:n != 4特判 ,不用什么高大上的凸包 就可以过了。 因为坐标为整数的情况下,只可能组成正方形。

AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#define MAXN 100
#define LL long long
#define Ri(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define Rl(a) scanf("%lld", &a)
#define Pl(a) printf("%lld\n", (a))
#define Rs(a) scanf("%s", a)
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define INF 0x3f3f3f3f
#define eps 1e-8
using namespace std;
struct Point{
    int x, y;
    Point (int x = 0, int y = 0) : x(x), y(y){}
};
Point A[110];
Point operator - (Point A, Point B) {return Point(A.x-B.x, A.y-B.y);}
Point operator + (Point A, Point B) {return Point(A.x+B.x, A.y+B.y);}
int dis(Point A, Point B){
    return (A.x-B.x)*(A.x-B.x) + (A.y-B.y)*(A.y-B.y);
}
int Dot(Point A, Point B){
    return A.x*B.x + A.y*B.y;
}
int D[10];
int main()
{
    int t; Ri(t);
    W(t)
    {
        int n; Ri(n);
        for(int i = 0; i < n; i++)
            scanf("%d%d", &A[i].x, &A[i].y);
        if(n != 4)
        {
            printf("NO\n");
            continue;
        }
        //sort(A, A+n, cmp);
        int top = 0;
        for(int i = 0; i < n; i++)
            for(int j = i+1; j < n; j++)
                D[top++] = dis(A[i], A[j]);
        sort(D, D+top);
        int d = D[0];
        bool flag = true;
        for(int i = 1; i < top; i++)
        {
            if(i <= 3 && d != D[i])
                flag = false;
            if(i > 3 && 2 * d != D[i])
                flag = false;
        }
//        int d = dis(A[0], A[1]);
//        A[n].x = A[0].x, A[n].y = A[0].y;
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


你可能感兴趣的:(hdoj 5533 Dancing Stars on Me 【醉了 o(╯□╰)o】)