D - Beauty of Array——ZOJ

D - Beauty of Array
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
Submit  Status

Description

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38


动规,一维DP






#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<set>
#include<vector>
using namespace std;
long long sum[100000+100],pre[100000+100];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		memset(sum,0,sizeof(sum));
		memset(pre,0,sizeof(pre));
		long long ans=0;
		for(long long i=1;i<=n;i++)
		{
			long long x;
			scanf("%lld",&x);
			sum[i]=sum[i-1]+(i-pre[x])*x;//动规,sum[]代表前i个数的和 
			pre[x]=i;
			ans+=sum[i];
		}
		printf("%lld\n",ans);
	}
	return 0;
}






你可能感兴趣的:(dp)