poj 2407 Relatives

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the questiosed above.

Sample Input

7
12
0

Sample Output

6
4


解题思路:

利用公式φ(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…..(1-1/pn) 
其中p1, p2……pn为x的所有质因数,φ(x)为x里所有质因数的个数。

代码如下:

#include<iostream>
using namespace std;
int main()
{
    int n,sum;
    while(cin>>n&&n!=0)
    {
        sum=n;
        for(int i=2;i*i<=n;i++)
        {
            if(n%i==0)
            {
                sum=sum-sum/i;
                n/=i;
                while(n%i==0)
                    n/=i;
            }
        }
        if(n>1)
            sum=sum-sum/n;
        cout<<sum<<endl;
    }
    return 0;
}




你可能感兴趣的:(poj,Relatives,2407)