HDU 3853 LOOPS(概率DP求期望)

传送门

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 4559    Accepted Submission(s): 1823


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.
HDU 3853 LOOPS(概率DP求期望)_第1张图片
The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
   
   
   
   
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
   
   
   
   
6.000
 

Source
2011 Invitational Contest Host by BUPT

 


题目大意:

给定一个 R 行 C 列的矩阵,一个人从(1,1)点走到(R,C),在每一个格子中,他能花费 2 个魔法值开启传送通道。假设他在 (i,j) 这个格子中,开启传送通道之后,有p[i][j][0]的概率被送到 (x,y),有 p[i][j][1] 的概率被送到 (x,y+1),有 p[i][j][2] 的概率被送到 (x+1,y)。问他到从(1,1) 到 (R, C)需要花费的魔法值的期望是多少。


解题思路:
一看是求的是期望那么我们可以倒着推,首先设DP[i][j]表示的就是从(i,j)这个点走到(R,C)所需要的期望,那么DP[i][j]等于什么呢?

DP[i][j] = p[i][[j][0]*DP[i][j]+p[i][j][1]*DP[i][j+1]+p[i][j][2]*DP[i+1][j]+2

移相可以求得:

DP[i][j] = (p[i][j][1]*DP[i][j+1]+p[i][j][2]*DP[i+1][j]+2)/(1-p[i][j][0]);

在这里需要注意的就是当1-p[i][j][0]相等的时候需要判断一下,直接跳过也就是不走那个格子,如果走那个格子,就永远也走不到(R,C)点,还有就是 当 i==R&&j==C的时候直接跳过DP[R][C]==0,最后保留三位小数

My Code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN = 1e3+5;
const double eps = 1e-7;
double p[MAXN][MAXN][5],dp[MAXN][MAXN];
int main()
{
    int R, C;
    while(~scanf("%d%d",&R,&C))
    {
        for(int i=1; i<=R; i++)
          for(int j=1; j<=C; j++)
            scanf("%lf%lf%lf",&p[i][j][0],&p[i][j][1],&p[i][j][2]);
        memset(dp, 0, sizeof(dp));
        for(int i=R; i>0; i--)
        {
            for(int j=C; j>0; j--)
            {
                if(i==R && j==C)///等于0
                    continue;
                if(1-p[i][j][0] < eps)///特判
                    continue;
                dp[i][j] = (p[i][j][1]*dp[i][j+1]+p[i][j][2]*dp[i+1][j]+2)/(1-p[i][j][0]);
            }
        }
        printf("%.3lf\n",dp[1][1]);
    }
    return 0;
}


你可能感兴趣的:(HDU 3853 LOOPS(概率DP求期望))