题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5533
Dancing Stars on Me
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 857 Accepted Submission(s): 469
Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.
Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
Input
The first line contains a integer
T indicating the total number of test cases. Each test case begins with an integer
n , denoting the number of stars in the sky. Following
n lines, each contains
2 integers
xi,yi , describe the coordinates of
n stars.
1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.
Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0
Sample Output
Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)
题目大意:给你n个点,判断能否形成正多边形。
解题思路:1、找到所有点之间的最短距离,这个距离即为正多边形的边长。接着找到所有与这个正多边形边长相等的个数,只有个数能够等于n,就输出YES
2、题目输入的是整数,所以除了正四边形,其他都不可以。
详见代码。
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
double x[1005];
double y[1005];
double len[1005][1005];
double sourt(int i,int j)
{
return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
int main()
{
int t;
scanf("%d",&t);
while (t--)
{
int n;
double Min=0x3f3f3f3f;
scanf("%d",&n);
int flag=0,num=0;
for (int i=1; i<=n; i++)
scanf("%lf%lf",&x[i],&y[i]);
if (n!=4)
{
printf("NO\n");
}
else
{
for (int i=1; i<=n; i++)
{
for(int j=i+1; j<=n; j++)
{
len[i][j]=sourt(i,j);
if (len[i][j]<Min)
Min=len[i][j];
}
}
for (int i=1; i<=n; i++)
{
for (int j=i+1; j<=n; j++)
{
if (len[i][j]==Min)
num++;
}
if (num==n)
flag=1;
}
if (flag==1)
printf ("YES\n");
else
printf ("NO\n");
}
}
return 0;
}