FatMouse' Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60255 Accepted Submission(s): 20245
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
贪心算法,需要处理价格和金钱为0
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <complex>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>
#include <cassert>
using namespace std;
#define LL long long
struct THING
{
int sl;
int jg;
double xjb;
}thing[1005];
bool cmp(struct THING A, struct THING B)
{
return A.xjb > B.xjb;
}
//#define DEBUG
int main()
{
#ifdef DEBUG
freopen("E:\\data.in", "r", stdin);
#endif // DEBUG
int money, things;
while (scanf("%d%d", &money,&things) != EOF)
{
if (money == -1 && things == -1)break;
for (int i = 0; i < things; i++)
{
scanf("%d%d", &thing[i].sl,&thing[i].jg);
thing[i].xjb = thing[i].sl*1.0 / thing[i].jg;
}
sort(thing, thing + things, cmp);
int t = 0;
double ans = 0.0;
while (money>=0&&t<things)
{
if (money>=thing[t].jg)
{
ans += thing[t].sl;
}
else
{
ans += thing[t].sl*1.0*(money*1.0 / thing[t].jg);
}
money -= thing[t].jg;
t++;
// printf("%.3lf\n", ans);
}
printf("%.3lf\n",ans);
}
return 0;
}