HDU2104 hide handkerchief 贪心

hide handkerchief

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3719    Accepted Submission(s): 1757


Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
 

Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
 

Output
For each input case, you should only the result that Haha can find the handkerchief or not.
 

Sample Input
   
   
   
   
3 2 -1 -1
 

Sample Output
   
   
   
   
YES
 

一个长度为N的环,每次前进M步,判断能否遍历到每一个点即可,即判断N,M的最大公约数是否为1即可。
//************************************************************************//
//*Author : Handsome How										       	 *//
//************************************************************************//
#pragma warning(disable:4996) 
//#pragma comment(linker, "/STA	CK:1024000000,1024000000")
#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <complex>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>                                                
#include <cassert>
using namespace std;
typedef long long LL;
int gcd(int x, int y) { return (x == 0) ? y : gcd(y%x, x); }
int main()
{
	//freopen("E:\\data.in", "r", stdin);
	//freopen("E:\\data.out", "w", stdout);
	int a, b;
	while (scanf("%d%d",&a,&b) != EOF)
	{
		if (a == -1 && b == -1)break;
		if (gcd(a, b) == 1)printf("YES\n");
		else printf("POOR Haha\n");
	}
	return 0;
}



你可能感兴趣的:(贪心)