FatMouse' Trade hdu1009(贪心)

FatMouse’ Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63198 Accepted Submission(s): 21342

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

简单贪心题,按性价比排序后优先取大的

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
    double j, f, x;
};
bool cmp(node a, node b)
{
    return a.x > b.x;
}
int main()
{
    int m, n;
    while (~scanf(" %d %d", &m,&n))
    {
        if (m == -1 && n == -1)
            break;
        node nd[10005];
        for (int i = 0; i < n; i++)
        {
            scanf(" %lf %lf", &nd[i].j, &nd[i].f);
            nd[i].x = nd[i].j / nd[i].f;
        }
        sort(nd, nd + n,cmp);
        double sum = 0;
        int flag = -1;
        for (int i = 0; i < n; i++)
        {
            if (m < nd[i].f)
            {
                flag = i;
                break;
            }

            sum += nd[i].j;
            m -= nd[i].f;
        }
        if (flag + 1)
        {
            sum = sum + nd[flag].x*m;
        }
        printf("%.3f\n", sum);
    }
    return 0;
}

你可能感兴趣的:(FatMouse' Trade hdu1009(贪心))