HDU4461:The Power of Xiangqi

Problem Description
HDU4461:The Power of Xiangqi_第1张图片
Xiangqi is one of the most popular two-player board games in China. The game represents a battle between two armies with the goal of capturing the enemy’s “general” piece.
Now we introduce some basic rules of Xiangqi. Xiangqi is played on a 10×9 board and the pieces are placed on the intersections (points). There are two groups of pieces marked by black or red Chinese characters, belonging to the two players separately. During the game, each player in turn moves one piece from the point it occupies to another point. No two pieces can occupy the same point at the same time. A piece can be moved onto a point occupied by an enemy piece, in which case the enemy piece is "captured" and removed from the board. When the general is in danger of being captured by the enemy player on the enemy player’s next move, the enemy player is said to have "delivered a check". If the general's player can make no move to prevent the general's capture by next enemy move, the situation is called “checkmate”.  
Each player has 7 kinds of pieces in this game. Their names, offense power and symbol letters are shown in the table below:

HDU4461:The Power of Xiangqi_第2张图片

Now show you the pieces of red player and black player, you are going to find out which player has the larger total offense power. Since Ma and Pao working together can have good effect, if a player has no Ma or no Pao, or has neither, his total offense power will be decreased by one. But the total offense power can't be decreased to zero, it is at least one.
 

Input
The first line is an integer T ( T <= 20) meaning there are T test cases.  
For each test case: The first line shows which pieces the red player has. It begins with an integer n ( 0 < n <= 16) meaning the number of pieces.  
Then n letters follows, all separated by one or more blanks. Each letter is a symbol letter standing for a piece, as shown in the table above.  
The second line describes the situation of the black player, in the same format as the first line.
 

Output
For each test case, if the red player has more offense power, then print "red". If the black player has more offense power, then print "black". If there is a tie, print "tie".
 

Sample Input
   
   
   
   
3 2 A B 2 A B 7 A A B C D D F 7 A A B B C C F 5 A A B B F 3 A B F
 

Sample Output
   
   
   
   
tie black red
 


 

题意:题目中已经给出了每个棋子的代表符号与能量,求双方总能量的比较结果,如果某一方没有马或者炮,能量要-1,但是能量最少必须有一点

思路:知道题意后就是水题一道

 

#include <stdio.h>
#include <string.h>

int flag1,flag2;

int check(char c)
{
    if(c == 'A')
        return 16;
    if(c == 'B')
    {
        flag1++;
        return 7;
    }
    if(c == 'C')
    {
        flag2++;
        return 8;
    }
    if(c == 'D')
        return 1;
    if(c == 'E')
        return 1;
    if(c == 'F')
        return 2;
    if(c == 'G')
        return 3;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int a,i;
        char s[5];
        scanf("%d",&a);
        int sum1,sum2;
        sum1 = sum2 = 0;
        flag1 = flag2 = 0;
        while(a--)
        {
            scanf("%s",s);
            sum1+=check(s[0]);
        }
        if( (!flag1 || !flag2) && sum1>1)
            sum1--;
        scanf("%d",&a);
        flag1 = flag2 = 0;
        while(a--)
        {
            scanf("%s",s);
            sum2+=check(s[0]);
        }
        if( (!flag1 || !flag2) && sum2>1)
            sum2--;
        if(sum1 == sum2)
            printf("tie\n");
        else if(sum1>sum2)
            printf("red\n");
        else
            printf("black\n");
    }

    return 0;
}


 

你可能感兴趣的:(ACM,HDU)