Count the string
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7682 Accepted Submission(s): 3573
Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input
Sample Output
题意:求所有的前缀串在原串中的匹配成功次数的和.
dp[i]表示i结尾的前缀串个数,显然自身是一个,并且从next[i]到i之间肯定不存在j使
得S[j...i]是前缀串,所以转移方程是dp[i]=dp[next[i]]+1.
注意取模.
#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;
#define maxn 211111
#define mod 10007
char P[maxn], T[maxn];
int n, m;
#define next Next
int next[maxn];
long long dp[maxn]; //dp[i]表示以i结尾的前缀串个数
void get_next (char *p) {
int t;
t = next[0] = -1;
int j = 0, m = strlen (p);
while (j < m) {
if (t < 0 || p[j] == p[t]) {//匹配
j++, t++;
next[j] = t;
}
else //失配
t = next[t];
}
}
int ans[maxn];
int main () {
//freopen ("in.txt", "r", stdin);
int t;
scanf ("%d", &t);
while (t--) {
scanf ("%d%s", &n, T);
get_next (T);
dp[0] = 0;
long long ans = 0;
for (int i = 1; i <= n; i++) {
dp[i] = (dp[next[i]]+1) % mod;
ans = (ans+dp[i])%mod;
}
cout << ans << "\n";
}
return 0;
}