1015 of greedy strategy

Problem Description
The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.
 

Input
* Line 1: Two space-separated integers, N and S. <br> <br>* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.
 

Output
* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.
 

Sample Input
   
   
   
   
4 5 88 200 89 400 97 300 91 500
 

Sample Output
   
   
   
   
126900
 

题目要求:计算n个星期生产酸奶的最小成本。

思路:1除了第一个星期外都可以上星期生产,但需要一定的保存费用。第一个星期直接加,后面的星期判断是否上星期的费用加保存费小于这个星期的保存费用,如果是则上星期生产,否者这星期生产。输出n个有费用总和即为最小费用。

细节:一定要读懂英文题意,如若理解能存储多个星期算法麻烦并wa。只能存储一个星期。

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
int main()
{
    int n,m,i,j,z1,z2,k;
    long long sum;
    int a[100000],b[100000];
    cin>>n>>m;
    for(i=0;i<n;i++)
    {
        cin>>a[i]>>b[i];
    }
    sum=0;
    for(k=0;k<n;k++)
    {
        if(k==0) sum+=a[k]*b[k];
        else
        {
            z1=a[k-1]*b[k]+m*b[k];
            z2=a[k]*b[k];
            if(z1>z2) sum+=z2;
            else sum+=z1;
        }
    }
    cout<<sum<<endl;
}


你可能感兴趣的:(1015 of greedy strategy)