PAT-PAT (Advanced Level) Practise 1012 The Best Rank (25) (简单模拟)【二星级】

题目链接:http://www.patest.cn/contests/pat-a-practise/1012


题面:

1012. The Best Rank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A
题目大意:

    简单排序题。比较坑的是,是1 2 3 3 5而不是 1 2 3 4 5。其他按优先级排就好!


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
struct stu
{
	char s[10];
	int C,M,E,A;
	int rank;
	char symbol;
	int val;
}store[2010];
bool cmp1(stu a,stu b)
{
	return a.A>b.A;
}
bool cmp2(stu a,stu b)
{
	return a.C>b.C;
}
bool cmp3(stu a,stu b)
{
	return a.M>b.M;
}
bool cmp4(stu a,stu b)
{
	return a.E>b.E;
}
int main()
{
	int n,m;
	char tmp[10];
	scanf("%d%d",&n,&m);
	for(int i=0;i<n;i++)
	{
		getchar();
		scanf("%s %d %d %d",store[i].s,&store[i].C,&store[i].M,&store[i].E);
		store[i].A=(store[i].C+store[i].M+store[i].E)/3;
	} 
	sort(store,store+n,cmp1);
	store[0].rank=1;
	store[0].symbol='A';
	for(int i=1;i<n;i++)
	{
		if(store[i].A==store[i-1].A)
		  store[i].rank=store[i-1].rank;
        else store[i].rank=i+1; 
		store[i].symbol='A';
	}
	sort(store,store+n,cmp2);
	store[0].val=1;
	for(int i=1;i<n;i++)
	{
		if(store[i].C==store[i-1].C)
		  store[i].val=store[i-1].val;
        else store[i].val=i+1;
	}
	for(int i=0;i<n;i++)
	{
		if(store[i].val<store[i].rank)
		{
			store[i].rank=store[i].val;
			store[i].symbol='C';
		}
	}
	sort(store,store+n,cmp3);
	store[0].val=1;
	for(int i=1;i<n;i++)
	{
		if(store[i].M==store[i-1].M)
		  store[i].val=store[i-1].val;
        else store[i].val=i+1;
	}
	for(int i=0;i<n;i++)
	{
		if(store[i].val<store[i].rank)
		{
			store[i].rank=store[i].val;
			store[i].symbol='M';
		}
	}
	sort(store,store+n,cmp4);
	store[0].val=1;
	for(int i=1;i<n;i++)
	{
		if(store[i].E==store[i-1].E)
		  store[i].val=store[i-1].val;
        else store[i].val=i+1;
	}
	for(int i=0;i<n;i++)
	{
		if(store[i].val<store[i].rank)
		{
			store[i].rank=store[i].val;
			store[i].symbol='E';
		}
	}
	bool flag=false;
	for(int i=0;i<m;i++)
	{
		flag=false;
		getchar();
		scanf("%s",tmp);
		for(int j=0;j<n;j++)
		{
			if(strcmp(tmp,store[j].s)==0)
			{
				printf("%d %c\n",store[j].rank,store[j].symbol); 
				flag=true;
				break;
			}
		}
		if(!flag)
		  printf("N/A\n");
	}
	return 0;
}



你可能感兴趣的:(入门,模拟,pat)