HDU 1004 Let the Balloon Rise (字符统计)

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 100790    Accepted Submission(s): 38657


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
   
   
   
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
   
   
   
   
red pink
 

Author
WU, Jiazhi
 

Source
ZJCPC2004

题意:输入一些单词,统计出现次数最多的.
注意:如果最多的可能有多个..

AC代码:

#include <stdio.h>
#include <string.h>
int main()
{
    int n,i,j,max,k;
    int a[1000]= {0};
    char color[1000][15];
    while (scanf("%d",&n)!=EOF,n)
    {
        for (i=0; i<n; i++)
        {
            scanf("%s",color[i]);
        }

        max=0;
        int a[1000]= {0};

        for (i=0 ; i<n-1; i++)
        {
            for (j=i+1; j<n; j++)
            {
                if (strcmp(color[i],color[j])==0)
                {
                    a[i]++;
                }
            }
            if(a[i]>max)
                max=a[i];

        }
        for (i=0; i<n; i++)
        {
            if (a[i]==max)
            {
                printf("%s\n",color[i]);
            }
        }
    }
    return 0;
}



你可能感兴趣的:(let,balloon,the,HDU1004,Rise)