Recaman's Sequence

Recaman's Sequence
Time Limit:3000MS     Memory Limit:60000KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a  m = a  m−1 − m if the rsulting a  m is positive and not already in the sequence, otherwise a  m = a  m−1 + m. 
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 
Given k, your task is to calculate a  k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a  k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658
 
    
//注意考虑a+b=0的情况。。
#include<stdio.h>
int main(){
    int m;
    int a,b,c;
    int t[100];
    while(1){
        scanf("%d",&m);
        if(m==0) break;
        scanf("%d%d",&a,&b);
         c=a+b;
        if(c==0) {
        	printf("0\n");continue; 
		}
        int count=0;
        while(c>0){
            t[count++]=c%m;
            c=c/m;
        }
        for(int i=count-1;i>=0;i--)
                      printf("%d",t[i]);
        printf("\n");
    }
}


你可能感兴趣的:(Recaman's Sequence)