hdu4764 2013长春网赛

Stone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1291 Accepted Submission(s): 910

Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc… Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.

Output
For each case, print the winner’s name in a single line.

Sample Input

1 1
30 3
10 2
0 0

Sample Output

Jiang
Tang
Jiang

Source
2013 ACM/ICPC Asia Regional Changchun Online

这道题,其实很简单

对于样例的解释

10 2//其中上面代表状态,下面代表输赢
10  9 8 7  6 5 4  3 2  1
0   0 1 1  0 1 1  0 1  1

30 3
30  29 28 27 26 25 24 23 22 21 20 19 18 17 16 15 
0   0  1  1  1  0  1  1  1  0 1   1  1  0  1  1
14 13 12 11 10 9 8 7 6 5 4 3 2 1
 1  0  1  1  1 0 1 1 1 0 1 1 1 0

1 1
1 
0

所以我们不难得出规律

#include<cstdio>
/* Name: Copyright: Author: Date: 20/04/16 18:38 Description: */

int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=-1,n||m){
        if((n-1)%(m+1))puts("Tang");
        else puts("Jiang");

    }
    return 0;
}

你可能感兴趣的:(hdu4764 2013长春网赛)