题目:HDU-1028
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1028
题目:
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16806 Accepted Submission(s): 11830
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
Sample Output
这道题目很简单,直接构建母函数就行了,不懂得看上一篇博客讲的原理吧。http://blog.csdn.net/qq_33171970/article/details/50663426
代码~~
#include<iostream>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<cstdio>
using namespace std;
const int maxn= 125;
int a[maxn],b[maxn];
int n;
int main(){
while(cin>>n){
for(int i=0;i<=n;i++){ //依旧不限制个数合并起来写
a[i]=1;
b[i]=0;
}
for(int i=2;i<=n;i++){
for(int j=0;j<=n;j++)
for(int k=0;k+j<=n;k+=i)
b[j+k]+=a[j];
for(int j=0;j<=n;j++){
a[j]=b[j];
b[j]=0;
}
}
cout<<a[n]<<endl;
}
return 0;
}
啦啦啦,好好学习天天向上啦~